Members Area

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

The Spaceteam Admiral's Club is a community of friends and fans of the game [Spaceteam]. Anyone can create an account but there are special rewards if you support my future projects by becoming a paying member!

Join the Admiral's Club- Henry (aka Captain Spaceteam)

Special Achievements are gone after update to 1.61 :(

I had the version 1.5 and achieved 4 from 6 possible achievements, but after update all achievements were gone. This is very bad, because I had a hard time with my friends to achieve this. I have screenshots as proove.

Now I can't restore them and can't achieve them again, because the challenge is over.

What can I do to restore them?


  • Did you lose the rewards too? I stopped showing the medals on the title screen but you should still have the 4 rewards from the achievements you earned.
    If they are gone let me know and I will send you an email with instructions on how to restore them.
  • They're gone, too. I lost my laser beam, alien pet, golden dial and this other waiting room.

    Thank you very much for helping me to restore these things. An instruction how to restore this would be nice.
  • Can you please send me this email with the instructions how I can restore the achievements?
  • I sent an email to the address in your account on March 29. Maybe it got caught by a spam filter? Let me know if you can't find it.
  • I guess I can just post the instructions here as well.
    If you have lost your Special Achievements here's how to get them back:
    - Go to the Admiral's Club members area using the banner at the bottom of the title screen (see screenshot)
    - Log in using the "Manual Login" button with this test account ID: 999905
    - Choose the "Special Achievements" menu item
    - Activate the achievements you are missing
    - Log out of the Test Account
  • Thank you very much :) it worked and I logged out again and you can delete this here if you want.

    The mail was really in my spam, sorry.
  • Access denied...
    What now?
  • Make sure you are connected to the internet.
  • Oh. That would do it.
  • I tried a bunch of times connected to the internet and it didnt work
  • Hm, that's odd. Just to be sure, the test ID is 999905 (four nines zero five). If that doesn't work try just 9999 (four nines).
  • Hm. Still doesnt work. Dont trouble yourself, though. Its not that important and because i am the only person with that problem, the problem is probably with my phone.
Sign In or Register to comment.